Can't create new project. Stuck on "waiting for backend to run"

Was able to create a couple of projects yesterday to understand the process, but then later in the day it stopped working when I was ready to create a project that I would stick with.

I tried the same with a different account today and it still didn’t work.

Everything seems to be fine. I was able to setup and start the local server. I’m seeing get /forest requests from the browser and a 204 being returned. There are no exceptions in the javascript console.

If I go to localhost:3310, then I see " Your application is running!"

Is something wrong with Forest? Or perhaps a rate limit on new project creation? I’m at a loss and I really want to proceed somehow!

Hi @Vlad,

Welcome to the ForestAdmin community and thank you for sharing your issue with us!

When performing the FOREST_URL="npm start" on the onboarding process, can you see a blue toaster saying that you admin panel is being updated ?

Also are the 204 request logged on your admin panel backend after the npm start command?

Hi @lamatt_v,

Thanks for the warm welcome!

I’m on the URL: http://app.forestadmin.com/foobartest/Development/Operations/install
with the heading: “Create your admin backend”

I don’t see a blue toaster. I only see a green pulsating light next to the text "
Waiting for your backend to run."

I see the 204 command repeatedly logged both in my terminal: “GET /forest 204 - - 0.632 ms”
and as successful requests in the network tab of the developer console in my browser.

Has this happened several times or only one?

If this has happen once could you kill all running lumber applications, go back to http://app.forestadmin.com, drop the foobartest project and try to go through the onboarding steps again again?

This keeps happening. I even tried using a different account and the same thing happened there. This is very odd because I was able to successfully create two projects yesterday before this started.

@Vlad,

I’m unable to reproduce the issue. Could you please give me your project name so I can see if anything is missing on our end?

Sure. The one I’m really trying to get to work is “schedule.warmspace.io”.

I have a 2019 MPB and I’ve tried this in Chrome, Safari, and Firefox

It seems that the forestadmin-schema.json file that is supposed to be sent when launching the app is not sent.

have you done the installation process through docker or NPM?

I’ve tried both NPM and docker, though mostly NPM

I was finally able to get it to work. I tried a different computer, still no luck with NPM, but managed to get it working with Docker. I’m not sure if the other computer was the fix or if you guys made a change in the meantime

But now I’m getting to the Unlock Your Data screen and I’m seeing the error: “Your backend is unreachable.”

Going to localhost:3310 works fine and I’m seeing these logs in the local server:

GET / 200 10026 - 6.786 ms
OPTIONS /forest/sessions 204 0 - 0.356 ms
OPTIONS /forest/healthcheck 204 0 - 0.163 ms

There is an on-going issue with the frontend that is affecting development environments. I would suggest you pause your deployment until they are fixed. Or you won’t know if it’s your fault or the Frontend UI regression bug they introduced just recently.

Check Dev Environment Not Reachable/On-Going Schema File Issue

So I got it working on a different computer (2016 Macbook). It worked for both NPM and Docker. I still don’t know why it stopped working on my newer MBP 2019, but for now I have what I need.

Hi :wave:,

like @jonl noticed we had an issue with dev environment during your onboarding, this was certainly linked to your issue :wink:

Indeed. It has absolutely nothing to do with the laptop being used.

I just tried again on my MBP to setup foobartest7 and ran into the same issue. Everything looks fine in both browser and local server (I see GET /forest 204) but it doesn’t move past “Waiting for your backend to run”. I’m fine at this point since my project is working in production, but if you like, I can offer whatever info you need to debug this issue.