Sudden Error Of 404

Feature(s) impacted

When I Run npm start it return an issue of

“url”: “”,

Observed behavior

Your application is listening on port 443.
[forest]   Checking need for apimap update...
[forest]   An error occured while computing the Forest schema. Your application schema cannot be synchronized with Forest. Your admin panel might not reflect your application models definition. Not Found
  "status": 404,
  "response": {
    "req": {
      "method": "POST",
      "url": "",
      "data": {
        "schemaFileHash": "2...c138....13850c"
      "headers": {
        "forest-secret-key": "2941ba5c...b1558f95cf70743f20",
        "content-type": "application/json"
    "header": {
      "server": "Cowboy",
      "report-to": "{\"group\":\"heroku-nel\",\"max_age\":3600,\"endpoints\":[{\"url\":\"\"}]}",
      "reporting-endpoints": "heroku-nel=",
      "nel": "{\"report_to\":\"heroku-nel\",\"max_age\":3600,\"success_fraction\":0.005,\"failure_fraction\":0.05,\"response_headers\":[\"Via\"]}",
      "connection": "close",
      "cross-origin-embedder-policy": "require-corp",
      "cross-origin-opener-policy": "same-origin",
      "cross-origin-resource-policy": "same-origin",
      "x-dns-prefetch-control": "off",
      "expect-ct": "max-age=0",
      "x-frame-options": "SAMEORIGIN",
      "strict-transport-security": "max-age=15552000; includeSubDomains",
      "x-download-options": "noopen",
      "x-content-type-options": "nosniff",
      "origin-agent-cluster": "?1",
      "x-permitted-cross-domain-policies": "none",
      "referrer-policy": "no-referrer",
      "x-xss-protection": "0",
      "content-type": "application/json; charset=utf-8",
      "content-length": "149",
      "etag": "W/\"95-7OjwLvXVab1eFhKCE6yUGpc7IdY\"",
      "vary": "Accept-Encoding",
      "date": "Tue, 05 Dec 2023 14:58:09 GMT",
      "via": "1.1 vegur"
    "status": 404,
    "text": "{\"errors\":[{\"status\":404,\"detail\":\"unknown secret key \\\"2941ba5cc79...5cf70743f20\\\"\",\"name\":\"NotFoundError\"}]}"
  "stack": "Error: Not Found\n    at Request.callback (/home/zigit/rebar-admin-producation-new/node_modules/superagent/lib/node/index.js:871:15)\n    at /home/zigit/rebar-admin-producation-new/node_modules/superagent/lib/node/index.js:1114:20\n    at IncomingMessage.<anonymous> (/home/zigit/rebar-admin-producation-new/node_modules/superagent/lib/node/parsers/json.js:22:7)\n    at IncomingMessage.emit (node:events:525:35)\n    at IncomingMessage.emit (node:domain:489:12)\n    at endReadableNT (node:internal/streams/readable:1358:12)\n    at processTicksAndRejections (node:internal/process/task_queues:83:21)"
[forest]   An error occured while retrieving your IP whitelist. Your Forest envSecret seems to be missing or unknown. Can you check that you properly set your Forest envSecret in the Forest initializer?
Your admin panel is available here:

Expected behavior

to run as usual

Failure Logs


  • Project name: RebarAdmin
  • Team name: …
  • Environment name: staging
  • Agent (forest package) name & version:
  • Database type:SQL
  • Recent changes made on your end if any:not recently

Hello @zigit_zigit,

Sorry to hear that.

It looks like the development environment (Development | nissanlevy when looking at the secret you shared) was removed quite a long time ago on the 21/07/2022.

You should be able to create a new development environment easily using the forest init command. It will give you a fresh environment with a fresh FOREST_ENV_SECRET.

Let me know if it helps.

Kind regards,

Hi again,

After looking again at your thread, we think you just used the wrong secret if you were trying to run your staging environment.

The environment secrets are accessible in the detailed view of an environment Project settings > Environments than just click on the Staging environment you will see the Environment secret (FOREST_ENV_SECRET) section.

Kind regards,

1 Like


I am sure that I am taking the right key
it is the key for the stagin enviroment
I checked it manny times
bu still get the issue

thank you

It is not I can tell you from the log you shared.

The FOREST_ENV_SECRET you use starts with 2941ba5c...
Your staging FOREST_ENV_SECRET starts with d0d01c...

Again, you can retrieve it this way:

Maybe you have hard set (by mistake) the value in your code instead of using environment variables?