Test environnement schema don't update

Expected behavior

I expect my environnement to follow the model structure build on the .forestadmin-schema file.

Actual behavior

The test environnement never update


We use the express forest-express-sequelize version “6.1.4”. Our file .forestadmin-schema is correctly build since our local environnement apply new change. I did verification on the docker build that the forestadmin-schema is like expected.

We have only this issue with our test environnement. The preprod environnement have all update apply (the build is actually the same).

Project : Askeet

Hi @Bruno_Maurice :wave: welcome to our community.
The .forestadmin-schema file is normally built only on a dev or development NODE_ENV on server start.
You should normally commit this file with your code base.
Have you got any error logs ?

Hi @Arnaud_Moncel thanks for your quick answer.

The file is commit and present with all change on the running instance.
Unfortunately I have not error log :s

Something realy strange is that some change apply on test have been deploy with the rest of the application on preprod and the schema have been update on preprod environnement but not in test environnement where the code was originaly present. Its realy the test environnement who bug.

It seem to have a desynchronization of your test env schema on our side.
Can you confirm me that your last deployment dated from 20/07 ?
These three schema must be identical?

We have deploy more change yesterday 22/07.
We deploy new change yesterday that did not apply ether so no it should be a slightly different of the preprod env

To be sure I understand you tried to deploy on your pre-prod env from your test env and the change not be applied, right ?

A no.

We did some dev last week on branch develop that have been deploy on test env.
This dev should updated some field and relation and custom field of our FA schema (it did localy). But the schema never update on FA test env.

We merge develop into our master that have been deploy on preprod since we had feature to release more importante that juste the FA schema change. We notice that the FA env preprod got all schema update that wasn’t apply on FA test env.

Yesterday we did some other change locally that have been deploy on test but the FA test continue to don’t synchronise the change we did. It’s like test env don’t care that the forestadmin-schema have some change.

Do you have this kind of env var FOREST_DISABLE_AUTO_SCHEMA_APPLY set in your .env file on your test environment ?

No never see this env variable

I’m trying to figure out what’s going on.
You say you have the correct .schema on test sever right ?
Have you restart your test server ?
Your test server can access https://api.forestadmin.com/ (with curl command for exemple) ?

Yes the .schema is the same as on local where the configuration work.
The instance restart each time we deploy new docker version of our application.

I don’t have curl on my docker but with wget I got :

/app # wget https://api.forestadmin.com/
Connecting to api.forestadmin.com (
wget: server returned error: HTTP/1.1 404 Not Found

I have the same result on preprod when I do a wget, so very not sure its the main issue.

1 Like

We’ve made some manipulations on our side.
Let me know if your test environment is well synchronized now.

1 Like

It seem to have fixe the issue. Great.
Thanks for your help, really appreciate.


Hi @Arnaud_Moncel

I start to have the same issue now with the production env.
We deploy some chance yesterday that is not accessible.

I did all verification (log at start of docker, presence of the change on fa preprod env, presence of table and element on db for the prod env…) without any found. I think there is a new unsync like last time.
Is it possible to have a lot at it ? It could be great to have a tool to force a sync in case of situation like that.


Hi :wave: @Bruno_Maurice, can you enter in the edit mode and try to see if your collection is present and set to hidden like this image ?


We have the same problem here. We developed new features yesterday including 3 new fields (two in one table, another in a second one).

All is fine in local environment with schema update, database with new fields, Forest with new fields. In our staging one, the database was also updated with our new fields but no change in Forest. The fields are not hidden, there are literally not here.

I think we have the same synchronization problem as discussed here.

Any idea?

Have a good day,

Project: Homeloop - Staging environment

Unfortunately the collection is not in the hidden place.
(I did the same feedback at first to my client ^^’)

Hi @Bruno_Maurice,
We had a second issue about your production environment.
It is fixed, you should now be able to access the new collections/fields you recently deployed in production.

Thanks for your patience.

1 Like

Great thanks @arnaud for you intervention everything seem good.