The "x" record you are trying to update is invalid

Feature(s) impacted

We have a table called “Case” with a smart field on it called “note” that on the “set” method of this field it updates a different table called note.

Observed behavior

Last week (it worked before) we started to get an error when we try to save new data on this field.
When we are in the Summary tab we click on the “edit” button, inserting new data and click on “Save” we get “The Cases record you are trying to update is invalid.”.
Another weird thing is that when we go over to the “details” tab and go back to the “summary” tab we are able to update this field.

Expected behavior

Ability to edit this smart field as it worked a week ago

Failure Logs

we dont get any log just the error message in the UI


  • Project name: Empathy
  • Team name: All team( foe example: Engineering)
  • Environment name: All (production, dev, etc )
  • Agent (forest package) name & version: forest-express-sequelize: 8.4.8
  • Database type: Postgresql.

Hello @Itai_Zaban. Welcome to our community.

So sorry to hear that. I’m contacting the team to investigate on this and see if something has introduced the issue recently.

And thanks you for your detailed Observed behavior, for sure it will help the team to understand. :pray:
We will get back to you if we need more information or if we find the issue.

Kind regards,

Hi @Itai_Zaban :wave: and welcome in our community :champagne: !

You got absolutely no error log in your browser console ?
This error happens when you got a validation error in your form, so meaning one of your field is missing while it should be field or is having a bad data.
We did release a fix on that part last week, validation on id field where totally ignored.
If your field is visible and has validation, it must pass this validation.

You should have an input in an error state (in red) with a description of why.

Let me know if it helps :pray:

1 Like

Hi @vince
thanks for your response :slight_smile:
I dont get any error and I dont have any validation on this field, its a simple smart field and when I add logs to the set callback it doesnt even go there.
Im attaching a screenshot

Okey can you try again but inside the “Details” view (as it is the exact same validation that is run)

As I mentioned from the details tab it works, and also if I go to the details tab and then back to the summary tab it works

Could you let me know what’s the name of your model. I can’t find any “case” collection :thinking: or maybe it’s not on your production environment ?

its “caseView” and its in our production environment.

The only “validation” I see on this collection seems to be on your “id” field :thinking:. Could you check that you got an “id” filled on your record ?

I have an “id” field. Do you have any explanation why it works when I go to the “details” tab and then back to the “summary” tab?

Could you check your network tab, is the data different on the call /forest/caseView/:caseViewId between Details and Summary ?

Hi, my team started seeing this same issue this week. We get the error “The Applicant record you are trying to update is invalid” when we edit fields in our Applicants table (called “application” in our database). If we go to the Details tab and then return to the Summary tab to try editing, the error does not occur.

I don’t think there is any validation on the Applicants table fields. Though, I am not sure if I understand what you mean by validation. If you could provide documentation on how validation is set up, I could check that better.

I see no error in my Google Chrome console when this happens, and I also do not see a new entry in my Network tab. (When I successfully edit an Applicant, a new entry in the Network tab appears with a name matching the applicationId, but no such entry appears when the error occurs.)

I hope this helps!

I also dont see anything in the network tab

Okey I’ve found the issue. I will create a bug ticket. But in the meantime, you can make your id field read only and it will fix your issue


Hey @Itai_Zaban and @Josh_Rogers,

A fix has been released. Do you still experience this issue ?

thanks for the update!
changing the id field to read only fixed the issue

It is working now, and I did not change our ID field to read only.
It seems the fix worked, thank you!

1 Like