'update' access forbidden on User

Expected behavior

Being able to edit a user

Actual behavior

When validating the changes, we have a message “update failed: Forbidden”.

Failure Logs

Server-side we have this log : ‘update’ access forbidden on User


This started to happen yesterday. Before that we could edit users without trouble.
It started with one user’s account (i’m talking about Forestadmin user here) that got this message, it was still working with mine, but when i gave him my account it started to have this problem too. And now i have this too when using my account.
We don’t have the problem in “development” environment

  • Package Version: same result with forest-express-sequelize v3 and v4
  • Project Name: ma-domiciliation

Hello @kmcb !

You’re using a very old version of forest-express-sequelize, I think you should migrate to a more recent one. We have a documentation available here to help you out during this process!

In the case it could help, please try to delete your cache and cookies on your web browser, and log back in! We’ve made some changes lately, and there’s a chance that doing this could fix your issue :slightly_smiling_face:

Hi Remi,
Thanks for the quick answer.
We already tried in private navigation, which should have the same effect as clearing cache and cookies.
Unfortunately we can’t migrate to > v4 right now, we would be impacted by the breaking changes and it’s was not planned for us to spend time on this project in the next weeks.
Fyi i already had a call with your support team yesterday, they said they’ll look into this issue but told me to create this topic anyway.

Hey @kmcb ,
To check if the latest changes solved your issue, logging in incognito might not really help as you need to actually clear all site data (while not being in incognito mode). Could you please try doing so (I attached a screenshot for chrome for guidance) and see if the issue persists :pray:?
Thanks a lot

1 Like

Everything seem to work fine again, thank you very much !