Updating Smart Action name does not change the action name displayed in Forest

We updated the name of a smart action. But the new smart action name is not displayed in Forest Admin frontend, where we still see the previous name. This is an issue related to the smart action name only: all the other changes to the smart action are in place correctly.
This happens since today: yesteday we had other changes to the very same smart action name and everything worked fine.

Expected behavior

We have a smart action defined like this:

collection('Booking', {
  fields: [
      // ...
  actions: [
      name: 'Create Custom Payment Deadline',
      type: 'single',
      endpoint: '/forest/actions/some-endpoint',
      httpMethod: 'POST',
      fields: [
        // ...
    // ...

And we can see the action correctly in the Actions drop down menu of the collection in Forest Admin.

Then we change something in the action (we changed the name and some enums in one of the action fields.

In the .forestadmin-schema.json file we see the changes correctly (diff of the relevant part of the file):

-      "name": "Create Custom Payment Deadline",
+      "name": "Payment Deadline — Create Custom",

After refreshing the browser page, Forest Admin is supposed to show all the changes we made.

Actual behavior

The action name is not updated in the Forest Admin frontend. This change to the code of the collection setting is not reflected in the admin panel (screenshot of the diff in the Forest collection definition file):

Screenshot 2020-06-10 at 10.50.44

Failure Logs

No logs with errors are displayed on our side.


  • Package Version: "forest-express-sequelize": "^6.1.4"
  • Express Version: "express": "~4.17.1"
  • Sequelize Version: "sequelize": "^5.21.9"
  • Database Dialect: Sequelize
  • Database Version: postgres (PostgreSQL) 12.2
  • Project Name: Sailsquare

Hi @Matteo,

When you refresh the forest page, did your forest page suggest you to refresh by displaying this kind of sentence in a toaster: “your schema changed, please refresh bla bla…”?

Hi @Sliman_Medini.

This is what we saw (we just had another try and we took a couple of screenshots).

First a toast saying that the update was in progress was shown in the lower right corner of the page:

Then, after about 10 seconds, a new toast with a “done” message was finally displayed:

So, it seems your UI is updated and should definitely show your last action name.
Let me reproduce this on my side and create a bug ticket :+1:

@Matteo, sorry I am unable to reproduce: updating a smart action name update the display on the UI.

Can you please tell me on which environment are you facing this?

Thank you @Sliman_Medini for your attenction.

The environment is Dev (local) Francesca.

I see well your booking smart action named Payment Deadline — Create Custom
I’ve started an action to refresh the layout of this environment.

Can you please tell me if it fixes something?

@Sliman_Medini I’m afraid nothing changed on our side:

Actually, this is not the only smart action we renamed… but we can’t see any rename in place :man_shrugging:


I understand that all your smart actions renames does not display on UI.
Did your perform some other changes at the same time? If yes, are these changes visible?
If no, can you please test now to make some dummy change other than smart action rename to check if it appear?

Thank you @Sliman_Medini
Actually, today we changed some other things, but we introduced these changes one by one. So today it was not the first time we renamed some smart fields. But the last change was not reflected in the UI (with this last change we just renamed the smart actions).

We also released all the changes in another environment (we released all these changes at once) and in this environment we see all the changes but the smart action name change. The second environment is dev-datamix.[undisclosed-name]

Now we tried with a “dummy” change to see what happens. We added a smart field:

// ...
   field: 'dummy',
   type: 'String',
   get() {
     return '5'
// ...

and this change is correctly reflected in the .forestadmin-schema.json (here I’m pasting only the relevant part of the file):

  "field": "dummy",
  "type": "String",
  "defaultValue": null,
  "enums": null,
  "integration": null,
  "isFilterable": false,
  "isReadOnly": true,
  "isRequired": false,
  "isSortable": false,
  "isVirtual": true,
  "reference": null,
  "inverseOf": null,
  "validations": []

As soon as we saved this change (new smart field) on the local development environment linked to Dev (local) Francesca, the UI shown the blu box “…currently being updated…”. The blue box holded there for about 5 minutes, then the green box saying “…new version has been deployed…” appeared.

But the new smart field is NOT visible.
Looks like something hanged in the UI?


So we have a larger problem than smart action, sorry for that.
Can we say that since today, you are unable to see any new changes on the UI?

@Sliman_Medini no problem, but I’m afraid you’re right.

Actually we didn’t try extensively, we just had a few minutes ago the test you suggested, because we didn’t want to scramble things up more than this :slight_smile:

But, as far as I can undertand, it looks like ultimately all the changes are not reflected in the UI any more, since today.

@Sliman_Medini not sure this helps, but this is not the only problem we’re facing today with the UI. I can’t say at all that these things are related (because it has been a long time since we last changed the badge colors), but we also asked for help about the color picker for custom badge colors field setting: Can't change the color for the "badge" display setting of a field

1 Like

I’ve answered to this other thread :+1:

About your issue refreshing the UI, I am disturbed because I can’t reproduce on my end (in production, too)

Unfortunately I was able to create & rename smart action, create smart fields, and refresh was ok.

Sorry but, may I ask you to double check:
-your are editing the good environment matching the UI you verify?
-does the trouble happen on all your environments? (maybe an issue related to some environment state)

I will ask to teammates if they have ideas about that.


It appears that there is an error in your layout configuration:

You must have an action field name which is an array containing “Due Date” instead of just a string.

Let me know if this fix your issue.

1 Like

Hi @Sliman_Medini. You’re right. We have an issue on our side. I apologize.
We’ll fix and retry within tomorrow morning and then I’ll give you feedback.
Thank you for your help.

1 Like

Hi @Sliman_Medini.
I can confirm that solving the issue on our side everything works fine.
Thank you for your support!