Virtual machine setup (vagrant)

Hi,

I’m trying to set up forest admin on a virtual machine (vagrant) that’s running on my machine.

I can see a bit in the documentation about any application host apart from localhost needing to use ssl but my virtual machine address doesn’t have this.

When I curl <my.vm.address>:3000 I get the page which says the backend is running but when I go to https://app.forestadmin.com it can’t connect because it’s looking for localhost.

I’ve changed the application host address to be my vm address but that doesn’t work, I’m guessing because it’s not using ssl.

Is there a way around this or something obvious I’m missing? I couldn’t find any related topics about setting forestadmin up with a virtual machine so maybe I’ve gone down the wrong path.

Any help appreciated cheers.

Hi Joe,

Welcome to our community! :slight_smile:

I think you’ve spotted well your issue and there is no workaround.
As written in this article:

Let me know if something remains unclear.
Thanks!

1 Like