Add button has disappeared for a role

Feature(s) impacted

Acces to action such as create is impossible for one of our role

Observed behavior

The green button + Add in the top left corner hase disappeared

Expected behavior

The button is visible and the users with the role “assistant copro” are able to use it


  • Project name: Sergic
  • Team name: Gestion
  • Environment name: production
  • Agent (forest package) name & version: syndic-one-rebirth 0,0,1
  • Database type: postgresql
  • Recent changes made on your end if any: None but we had to ask for a backup last week after the push of a wrong backend ( Lost a collection in prod and staging - #3 by mduhez )

Here for the related data Batiment in the collection integrations and for a user with the role “assistant copro” :

And for the same context with a manager user :

As far as I know, the permission are set accordingly to the expected behaviour

Thank you

Hello @mduhez,

Thanks for reaching out :raised_hands:

Could you please:

  • Tell me what is the (technical) name of this collection? “buildings”?
  • Show me the role settings of “assistante copro” you see in Forest Admin for this environment + collection?

Thanks a lot.

Yes I am talking about the collection buildings.

I have tried to tick off and on the permissions to “force” the permission to refresh but it didn’t help


Oh, I have an idea :bulb:

From what I can see, you’re adding data from the related data.
This means that you’re actually editing the parent record (which is an Integration) by adding a new value to its relationship (Buildings).
→ So you need to add the Edit permission on Integration collection on the “Assistance copro” role too.

Let me know!

Yes, the problem is solved with this change.

I think the problem appeared with the rollback we asked last week, somme permission must have been lost in the process. Now it seems good and I know the way to olve the problem next time.

Thank you :slight_smile:

1 Like