Can't see smart actions

:warning:This is a template you must use to report issues. :warning:
You can also drag images, videos and include Preformatted text.

Feature(s) impacted

Smart actions

Observed behavior

Smart action is not showing up because of permission issues

Expected behavior

even though I added permission to see the smart actions to a role, it still shows the warning (in layout edit) that the role doesn’t have permission

Failure Logs

as you see, the admin role does have all of the permissions on all environments

but here is the alert that I get in the smart action setting in layout edit

NOTE: this issue only appears on test and acceptance environment, and on the production I can see it without any issue


  • Project name: Gaming Platform
  • Team name: Operations
  • Environment name: Test and Acceptance
  • Agent type & version: …
  • Recent changes made on your end if any: added new smart action, and deployed it

Hello @Reza_Erami ! Welcome to our community. :confetti_ball:

Let’s try to find the culprit. :slight_smile:

Have you looked at the configuration for all environments? On your screen, you’re only showing Production environment role configuration.

Can you check again your settings for those environments? Are those environments up-to-date code-wise (the smart action is well implemented)?

Let me know if you find anything misconfigured. :pray:

Kind regards,

thanks for your response
ah yes now I see, I thought project setting is a global setting that applies on all environment, so yes when I selected another environment I saw that it still doesn’t have the correct permission

1 Like

Hey again @Reza_Erami,

Indeed, we have splited roles permissions per environment. Sorry for the confusion.

Have a pleasant journey with Forest Admin. Don’t hesitate to give us feedback so with can improve the user experience.

Kind regards,