This smart action is not allowed by your Role. It will not appear in the UI

:warning:This is a template you must use to report issues. :warning:
You can also drag images, videos and include Preformatted text.

Feature(s) impacted

Please describe in this mandatory section the feature(s) that will be discussed in this topic.

Observed behavior

Please describe in this mandatory section the current behavior you observe.

Expected behavior

I should see “actions” button UI

Failure Logs

In this optional section, please:

  • include any relevant log snippets if necessary,
  • or remove this section if left empty.

Context

Please provide in this mandatory section, the relevant information about your configuration:

Hi @bashir

This message is here to warn you, that your Role does not allow to use this smart action.

By default, new actions are disallowed to everybody, to avoid security issues

To change that:

  1. go to project settings
  2. go to roles
  3. choose the role you are assigned to
  4. edit smart action permissions
  5. allow the smart action

Screenshots:
image

Hi @romaing, Thanks for your feedback, I checked, but I didn’t see the new Smart action I’ve created.

It should be there once the agent is deployed to a remote environment :man_shrugging:

Are you having the issue in your development, staging or production env?

No, it is on Staging

Roles are differentiated by environment.
When you check the roles for the staging environment, is the smart action there?

  • The toggle on “staging” should be enabled
  • When you click on the word “staging” in the left column it will open the role settings for that environment.
  • the smart action should be there, and the “trigger” permission enabled

If the agent was deployed on that environment, it should be there

(If that fixes the issue you are having, I’ll open a ticket so that a breadcrumb is added on this page to make it clearer that roles are configured by environment)

Ohh, yes I see it now, and checked (trigger)… but it’s still showing it’s not allowed by my role :man_facepalming:

@romaing I don’t know if you will be available for a call now?

Even if that would be very convenient sometimes, in the way the community support is set up, devs don’t take calls with customers :frowning:

That is unfortunate :frowning:

I see in the screenshot that you allowed the ‘Create refund’ for the admin role on the staging environment.

Can we check

  • that you user is using the admin role? (see screenshot)
  • that you still have the yellow popup saying “this smartaction is not allowed by your role” that you shared on the very first post?