Error updating a field's settings

When trying to update a field we are getting the following error:

And this is the error returned from the network:
“status”: 422,
“detail”: “Invalid patch value (path: “/collections/slug/layout/fields/slug-type/widgetEdit”, op: “replace”, value: {“name”:“dropdown”,“parameters”:{}}): ValidationError: child “parameters” fails because [child “isSearchable” fails because [“isSearchable” is required]]”,
“meta”: {},
“name”: “ErrorHTTP422”

This doesn’t happen on other fields

Hello @Eyal_Hakim,

Thank you for reporting the issue.
We are working on it and it will be solved soon.


Hi @Eyal_Hakim,

Could you please tell me a little more about your field so I can try to reproduce your issue?

Are you configuring the dropdown widget on a smart field or not? Also the field type would help
Are you able to access the settings of the widget?
Is it a static or dynamic dropdown?
Could you maybe share a screencast of what you exactly do before the error?

Is the error happening in all the environments or just this one? If just one Please tell me which environment is it?
Plus could you provide me the name of your project?

Thank you

Hi, it worked when I changed the field from dropdown to text. I then reverted it back to a dropdown and everything now works.

1 Like

Hi @Eyal_Hakim,

Super cool that it’s working for you.
Even if it is ok for your case, I think we still have a failing scenario that leads you to the issue.

Can you please explain which step you followed to reproduce the issue?


I’m not exactly sure, the field was defined as a dropdown in the input configuration. Didn’t save no matter which change I tried making. Once I changed it to text it was able to save, then I brought it back to a dropdown and everything worked from there on.

1 Like