Error updating item in dev environment: "... removed from the module tree but is still active!"

Strange error trying to save an item just now, removing a related item, which I swear I’ve done in production…

Expected behavior

Saves like normal

Actual behavior

Does not save

Device 619 update failed: A copy of Notifiable has been removed from the module tree but is still active!

Note ‘Notifiable’ is a rails concern in my app


In dev environment.
Rail app with 6.1.1 version of the gem… otherwise works fine

Please provide any relevant information about your setup.

  • Package Version: forest_liana (6.1.1)
  • Express Version:
  • Sequelize Version:
  • Database Dialect: postgres
  • Database Version: 11
  • Project Name: Dispatch

Hi @Kevin_Davis,

In order to have the full context of this problem, can you please give more details about your configuration and the failing scenario?

  • The database schema of the involved tables?
  • The relevant forest models?
  • What is the type of record you try to save?
  • What is the type of related data you try to remove?
  • What is the entire scenario (create X, drop Y) you want to achieve when you reach the Device 619 failed
  • Can you share every log line from the browser and from the API relative to the issue?


Database schema: not sure what you mean ? Development environment
Forest models: encountered this removing a ‘Room’ from a ‘Device’… can confirm this didn’t happen in production just now
Type of record trying to save: ‘Device’
Related data trying to remove: ‘Room’
Scenario: a ‘Device’ is signed into a room when the room association is present - I was trying to remotely sign some devices out of rooms where the hospital patients in the room wouldn’t be able to access the device
Logs: tried again just now and good news / bad news is that it worked fine where it consistently failed yesterday

Feel free to look at my account logs for my development environment if it helps


Hello @Kevin_Davis,

To be sure I understand your last message correctly, does everything work as expected on your end now?

We had some issues yesterday which may have hindered authentication and permission checking.

Correct - just tried again and everything seems to be working fine. Thanks for confirming!

Hi @Kevin_Davis,

Nice to know everything is working on your end. I’m closing this topic :+1: