How to create a local environment on forestadmin?

Hey guys!

I’m trying to create a new local environment on my forest admin but it’s asking for an https url (my local url is http), I followed this tutorial and it’s using htttp : Environments - Developer guide
Can you please help me?

Project name: NostrumCare


You can only have one local environment on forest admin (this is called the development environment). All other environments are remote and must be accessible through HTTPS for security and technical reasons.

Why do you need to create another development environment?

Hey @GuillaumeGautreau,

Thanks for your reply!
the thing is, how do I switch on the local environment, because I it looks like I only have remote environments :

Thanks for your answer,

Regarding the fact that you don’t have a development environment yet, my previous answer was not accurate.

There is actually a bug that prevents from displaying the instruction in the application. I reported this bug and we will tackle it soon.

Here is what you can do to create a new development environment:

  • Install the forest cli with npm install -g forest-cli
  • Copy the source code from your production environment in a local folder
  • Run the command forest init inside this folder
  • Copy/paste the environment variables displayed in the console into the .env file in your folder

You’ll find the documentation about the command forest init here.

1 Like

Hello @GuillaumeGautreau.
I also can’t create my development environment on my local machine (as I wasn’t the creator of the forestadmin projet to begin with, i don’t have a development environment at the moment).

The project name is HOLIVIA

I have run the forest init command. Copy/paste the environment variables inside my .env file.

There is the output of the command forest init

Selecting your project
√ Analyzing your setup
√ Checking your database setup
√ Setting up your development environment
> Here are the environment variables you need to copy in your configuration file:

> Automatically copied to your clipboard!
√ You're now set up and ready to develop on Forest Admin
> To learn more about the recommended usage of this CLI, please visit

I still can’t see the development environment on my forestadmin account.

My APPLICATION_PORT is 5000 as I display my environment on localhost:5000

Do you have any tips on how to redo the all procedure again ?

Thanks by advance for your feedback

Hello @elviajero971 can you please create another thread for your problem? I’m not sure it’s related to the previous one. Thanks

thanks I just did it! Issue creating local environment