Development environment is gone

Feature(s) impacted

I don’t have access to my development environment anymore.

Observed behavior

I can’t switch to the development environment:

When I launch my rails server in local, I get the following error:

Cannot find the project related to the env_secret you configured. Can you check on Forest that you copied it properly in the forest_liana initializer?

Forest_liana.rb initializer didn’t change:

ForestLiana.env_secret = Rails.application.secrets.forest_env_secret

ForestLiana.auth_secret = Rails.application.secrets.forest_auth_secret

ForestLiana.application_url = Rails.application.secrets.forest_application_url

ForestLiana.forest_client_id = Rails.application.secrets.forest_client_id


  • Project name: lalanguefrancaise
  • Environment name: Development
  • Agent (forest package) name & version: Rails 6 ; forest_liana-7.8.1
  • Database type: Postgres
  • Recent changes made on your end if any: No change

Could you please help me get back access to the development environment? Thanks.

Hello @nico_lrx

We have proceeded to an automatic migration for all of our development workflow v1 to the v2 (you should have received emails explaining this and inviting you to do it before a specific date), you can learn more about this migration here.

You can learn more about the new development workflow and how to create a new development environment here

My bad, I didn’t see the emails! Thanks.

Hello @nbouliol,
Apparently, I have to contact support to ask my project to be “ready to migrate”. I do not see the “Learn more” button in the environment tab of my project “lalanguefrancaise”.

Could you please give me access? Thanks.

Hello @nico_lrx

We have already migrated all the projects (including yours) to the development workflow v2.

You can check the documentation to set up a development environment.

Hello @nbouliol,
Thanks, I took the following steps from the documentation:

forest init

I added the environment variables in my application.yml file, restarted the server, then:

forest branch development

But my development environment is still not deployed apparently. Not sure how to deploy it to access my development Forest Admin dashboard?

My rails app is running on localhost:3000

Hello @nico_lrx

Sorry for the delay

To deploy your environment and see it live, you can click on the deploy button

Hello @nbouliol ,
Sorry, I didn’t see that button :sweat_smile:

How am I supposed to get an HTTPS address locally?


Okay, found the solution in the doc with ngrok. It’s a pity we can’t use the dashboard just running our local server. Thanks for your help.

Hey @nico_lrx,

you can totally run your server on your localhost, there is no restriction on that :+1:.
I just think you needed to start your server first no ?
Because I’m using environment on localhost on my side :thinking:

Yes, but the fact that we need to use an https protocol with ngrok is not the best. Having a fixed ngrok URL is a paid feature so each time I want to use ForestAdmin in my local environment, I need to change the new ngrok URL in the Forest development environment settings and in my Rails app :wink:

Before, I only had to start my rails server and I could use my development ForestAdmin dashboard.

No i mean you don’t need ngrok :sweat_smile:. I’m not using ngrok, I just have a project on localhost ^^
So it should work for you too :thinking:

Oh! I just tried with http://localhost:3000 and it works!

Sorry, I got confused about the message saying it must be HTTPS to make it work when you create a new environment:

Thank you! :smiley: