Hung on 'Unlocking your data Forest Admin is validating your identity on your environment.'

Expected behavior

That I have access to my dashboard after setting up local server.

Actual behavior

When accessing my dashboard on:, a modal is hung on ‘Unlocking your data
Forest Admin is validating your identity on your environment.’


Just installed forest admin server on my local machine. Postgresql server is running on port 5432, and can connect to it using psql -U <username> and entering a password at the prompt.

Any help would be much appreciated,

Hello @cooki,

I will try to help you find the culprit. :slight_smile:

This modal show you the authentication step to your backend (process during which we make a secured connexion between your browser and the agent).

I have a few questions:

  • Which forest liana are you using ? Also the version would be appreciated.
  • Can you share your agent (backend) logs ?
  • Finally, can you open the Network tab and find the response from the failing call (I presume /forest/authentication/callback has failed).

Kind regards,

Hey @morganperre, thanks for the quick reply.

Inside my forestadmin-schema.json is the following

  "meta": {
    "liana": "forest-express-sequelize",
    "liana_version": "7.11.2",
    "stack": {
      "database_type": "postgres",
      "engine": "nodejs",
      "engine_version": "14.10.0",
      "orm_version": "5.15.2"

And my forestadmin.js file holds the following: const Liana = require('forest-express-sequelize');

My backend logs are the following:

POST /forest/authentication - - - - ms
OPTIONS /forest/authentication 204 0 - 0.186 ms

And by looking at the Network tab, the authentication callback returns a 204, you are correct.

Thanks for those informations.

It’s weird. So if I understand, you have an infinite spinner (with this modal “Unlocking your data”) ?

I’m not able to reproduce on my side. Can you share a screenshot from the Network Tab ? The callback should return a status 200 and the token in the response.


That’s correct, the modal has an infinite spinner, here is a screenshot of the network tab.

Hey again @cooki,

I can see your backend never responds to the authentification call (pending status on your screenshot).

Dummy question, have you finalised your onboarding ? :eyes:


Well, i didnt see a clear prompt about the onboarding process haha where is that started ?

By Onboarding means: “When you create a new projet, you follow multiple steps to setup the project”

I made an assumption that you just created a new project by saying “after setting up local server.”

Let’s have more informations.

  • How do you create the project ? From an existing one or a new one ?
  • Which process do you follow to setup and start your backend ?

Kind regards,

My steps were:

  • created a pgsql db and user with access
  • created new FA project, selected the from existing pgsql db option.
  • installed lumber cli
  • ran the project create command
  • cd into my newly created project
  • ran npm start
  • navigated to the url displayed in my terminal

Am i missing something ?

Hello @cooki,

What you have done seems right to me.

A last try: Can you share the Header from the Authentification pending call ?

Otherwise: I think the best solution is to re create a new project from scratch.

Sorry for not being able to help you that much. :slightly_frowning_face:

Hey @morganperre , the request header is the following:

Accept: */*
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.9
Cache-Control: no-cache
Connection: keep-alive
Content-Length: 23
Content-Type: application/json; charset=utf-8
Host: localhost:3310
Pragma: no-cache
sec-ch-ua: " Not;A Brand";v="99", "Google Chrome";v="91", "Chromium";v="91"
sec-ch-ua-mobile: ?0
Sec-Fetch-Dest: empty
Sec-Fetch-Mode: cors
Sec-Fetch-Site: cross-site
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.106 Safari/537.36

Small note: I created a new project on my macbook and it worked very smoothly. The problem I am encountering is when running a project from WSL2 on a windows 10 machine. Though If navigate to http://localhost:3310/ I get the “Your application is running” page of the backend.

Thanks again.

Hy @cooki,

Ok, I’m not really an expert of WSL2. Maybe there are still some limitations that prevent to run your agent (backend).
I know you can run the agents on docker if you’re using windows. I think it’s the simplest way to do the trick.

Side question: Can you work on MacOS instead of Windows ?


Hey @morganperre

I tried to run docker but encountered the following message:

And when I go to Environment Settings, I see the following screen:

Please advise, thanks.

Hello @cooki,

Your authentication issue seems to be fixed as you do not have the popup showing again, great !

I wrote a note on how to setup a project using windows and docker with a linux subsystem.

Did you follow the same steps as I do ?

Kind regards,