If a user already exist, they are unable to join an exist project

​I added an existing forest admin user to my project. The user (Michael) received an invite link; however, he still wasn’t unable to view my project after clicking on the link.

Expected behavior

​When a user clicks on an invite link, they should be able to view the project.

Actual behavior

After the user clicked on the invite link, it prompted him to sign up. Once he entered his email address, it said, “email already exists.”

I told him to try signing into his forest admin account first. Next, I told him to click on the link in his email address again. However, it took him to a blank project screen.


Please provide any relevant information about your setup.

  • Express Version: ~4.16.3
  • Sequelize Version: ~5.15.1
  • Database Dialect: mysql
  • Project Name: theCXN Administration

Hi @james-janetech,

Thank you for sharing your issue with us!

I tried to reproduce the issue on my end but I haven’t been able to do so. Either when already logged in and not.

Could you try to invite this user again and/or remove the pending invitation if there is any?

Pending invitations can be found on the project settings’ user tab.

If the user is already sign in he should see a message like this one and then see the project among his project list.

Let me know if the user is still unable to join and see the project after that

My user is seeing the following when I send him a new invite link.

And when logging in he does not see the project among its project list?

Here’s a screenshot of what he’s seeing.

@james-janetech, I’m not able to reproduce the issue.

I’ll trigger the email to be resent for the invitation.

Could the user try to go into an incognito browser and try to use the invitation link from there?

If that does not work, maybe a screenshare of the complete process might help to see if something wrong happens. This screenshare could be done using loom

@james-janetech, this screenshare stops before logging in. If the user clicks on the login link on the top right corner and enters its credential he should then be able to access the project.

1 Like

That worked. The user didn’t see the login in the top right corner.