Lumber update do not update ForestAdmin

Hi, I’m using your service and I updated my db models, but it’s not updated on ForestAdmin dashboard. I deleted old models and use ‘lumber update’ to recreate them, and no changes. Can you help me ? Thanks

Hello @John06 and welcome on our community forum ! :slight_smile:

What version of lumber are you currently using ?

Hi, I’m using Lumber 4.1.10

Do you have a config/database.js file in your repository ?

Yes I’ve config/database.js file

What are the logs you have on your server side when running this command?

It says that the templates are created without any problem, and when I look at the files, the new information is well displayed.

Only Forestadmin is not updated

Hello @John06,

If I understand, you already performed these tasks:

  • Delete files under ./models/*.js
  • Run the command lumber update
    • Then you were able to see your new models files under ./models/
  • you expect to see new models content in Forest UI.

Is all that true?
Please note that your server needs to be restarted in order to have changes sent to Forest.

Can you please describe the model fragments that are in the new models but are absent from forest UI? For example, you added a new field, drop a table, etc.

Also please share your project name.


Yes it’s all true ! I restarted the server already !

transactionId: {
  type: DataTypes.STRING,


isBot: {
  type: DataTypes.BOOLEAN,
  defaultValue: false,
  allowNull: false,

I received the project name, thanks.

The issue is related to your dev environment, that’s it?

The latest Forest schema receptions I can see were on July 8th and 7th.
They did not trigger a schema change.
In your dev environment, the forest schema date is 23/06/2021 11:18:50. Is it normal from your side?

That may certainly mean your server did not send the schema to Forest after this date.

Can you please:

  • Restart your server again
  • Post here the date of the restart
  • Check the server logs for errors while sending the schema
  • Check is reachable for your server


I restart server `NODE_ENV=production npm run start" at 07/16/21 3:11 PM UTC

I tried to ping and 100% packet loss ! I think it’s the reason!

Hi @John06,

I received your IP by private message, thank you.

We do not have any blacklisting features on our side.
As mentioned here, successful communication happened until 8th of July. Maybe you can rely on this date with changes in your infrastructure?


Also, please note that when you have NODE_ENV=production it will not regenerate the schema.
This is the desired behavior: effectively, when in production, the forestadmin-schema.json has to come with the release, and should not be edited directly on production.


I saw that your server is hosted on Heroku, maybe my IP is blacklisted on their side ? Pretty strange that I can’t ping

No I didn’t change anything on my infra

Hi @John06,

Did you notice my previous message about NODE_ENV?
It seems to be the source of the problem.


Ok you right ! I ran development env and it’s up to date ! Thanks !