Lumber update doesn't recognize liana version

I followed this guide for upgrading to v7.

I’ve seen this guide for using the command, but when I run it, an error throws. I don’t see what else I can do to get the command to pick up that I am using the correct version.

The interesting thing is that when I did the initial upgrade, I had this error. Then, I did something that fixed it and the command worked fine. Now, trying it again a few days later, the error has popped up again.

Expected behavior

lumber update executes without errors and updates my models

Actual behavior

davidketch > lumber update
> The liana is incompatible for update: Your project is not compatible with the `lumber update` command. You need to use an agent version greater than 7.0.0.


Please provide any relevant information about your setup.

  • Lumber Version: 4.1.8
  • Express Version: 4.17.1
  • Sequelize Version: 5.15.1
  • Database Dialect: PostgreSQL
  • Database Version: 12.6
  • Project Name: xy-planning-network

Here’s my package.json:

  "name": "xy-forest-admin",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "start": "node ./server.js"
  "dependencies": {
  "axios": "^0.21.1",
  "body-parser": "1.19.0",
  "chalk": "~1.1.3",
  "cookie-parser": "1.4.4",
  "cors": "2.8.5",
  "dateformat": "^4.5.1",
  "debug": "~4.0.1",
  "dotenv": "~6.1.0",
  "express": "~4.17.1",
  "express-jwt": "6.0.0",
  "forest-express-sequelize": "^7.11.1",
  "morgan": "1.9.1",
  "pg": "~8.2.2",
  "require-all": "^3.0.0",
  "sequelize": "~5.15.1"

Hey @David_XYPN :wave:

I’m able to reproduce. It seems to be a simple mistake in the lumber update code checking for the version …
If you really need the lumber update to work right now, I suggest you to just put ^7.0.0 in the your package.json, and restore your value once lumber update ran.

We’re working on the fix, and I’ll ping you once it is released.

Thanks for reporting :pray:

Yep, works switching to forest-express-sequelize: ^7.0.0. I must have been playing around with versions. Good luck squishing that bug :hiking_boot: :bug:!

Hey @David_XYPN,

It should be fixed in lumber@4.1.9. Let me know if it wasn’t the case, but it looks like everything works as expected on my end now.

Thanks again for reporting this issue :pray:

Yes, installing lumber-cli@4.1.9 and using forest-express-sequelize: ^7.11.1 in my package.json. For what it’s worth, it works with the latest version as well forest-express-sequelize: ^7.11.2.

1 Like