Problem with teams this morning

Hi team,

Did you make some update this morning?

I have a user who belongs to two different teams: Prez and Compliance.

From around 9h30 / 9h35 this morning, there is some strange behavior with the team concept. It was running well before that time, and nothing changed on our side.
Now, when he is switches to the Compliance team, and accessing the associated collections, the req.user.team value is returning Prez instead of Compliance, and so, the programme is not running as expected.

It is in Production environment.

Could you please have a look and tell me if something has changed recently?

Thanks for your help
Best regards

My setup:

    "database_type": "postgres",
    "liana": "forest-express-sequelize",
    "liana_version": "6.6.3",
    "engine": "nodejs",
    "engine_version": "12.13.1",
    "orm_version": "5.22.3"

Hi again,

Waiting for your answer, I removed the Prez team from this user.
Because we were blocked.

Thanks

Hi @Louis-Marie,

Thank you for sharing your issue.

I haven’t been able to reproduce this issue, when switching team, the right one is passed through re.user.team.

I have got a few questions to narrow the problem:

  • Is that an issue that still happens or was that a one time one?
  • On which call to your API was that team issue happening? (listing on a collection, performing an action…)

Hi @lamatt_v

I was not able to reproduce the same issue on another user.
It was recurrent. Even after logout and login. Even after hard refresh of the browser.
And because it was urgent, I temporary removed the Prez team from this user.

It was happening when he accessed to a hasMany relation named kycDocuments of a kyc collection record.

The route /kyc/:id/relationships/kycDocuments is overrided, and I am testing the team at the beginning of the code before going further.

Here is an excerpt:

router.get('/kyc/:id/relationships/kycDocuments', Liana.ensureAuthenticated,
  async (req, res) => {
    console.log(`Access to kycDocuments requested with team: ${req.user.team}`);

But I insist, it was running well before 9h30.
EDIT: it was running well up to 9h32. First problem occurred at 09h40 (Paris time).
So, what happened this morning?

Thanks.

Help please!

The problem occurs again now.

This user is already removed from the Prez team, but I still have the Prez team reported in req.user.team.

So, I tried to remove the user to create it back later, but I am getting an error:

What is happening now?

Thanks

I’m still unable to reproduce the issue.

Could you please share with me your project name so I can give a look at it on our end and see I I notice anything wrong.

As for your concern, we did not release anything that impacted the teams this morning. However I’ll do my best to dig into it and find what’s happening to yours.

@Louis-Marie, we finally managed to reproduce the bug. We’ll work on a fix asap, I’ll keep you updated

Hi @lamatt_v

I haven’t seen your previous request because I was in a meeting, sorry.
But happy to hear that you finally reproduced the bug.

Thanks

@Louis-Marie ,

A fix should have ben released by now. It should prevent users to fall into this idle state. However, if you are already locked with this single same team sent over each calls state, you’ll need to log out and in again to come back to a clean state.

Let me know if this fixed your issue.

Best regards,

Hi @lamatt_v

I am sorry but the base problem is not solved yet:

After having asked the user to log out, quit, relaunch the browser and reconnect, the req.user.team variable still contains Prez as team, while the user belongs only to team Compliance now.

What should I do now?
Do you want me to retry to remove the user?

Thanks

Could you try to ask the use to empty its cookies please?

Hi @lamatt_v

Yes, that works now after the removal of the cookies.
It was a nightmare!

Thank you very much for your help.

1 Like