Problem with view selection

Hello, I have problem with selection of views, it does not work properly anymore. If I create any smart view(even empty for test) after I choose it, it applies but shows error in browser console “Uncaught (in promise) TypeError: r.adapterFor(…).layoutBatchUpdate is not a function” and then after page reload it shows the old view again instead of the new selected. And this problem is for all models, for all views. I can not even choose the standard table view if smart view was selected earlier.
I would be grateful for any help.

  • forest-express-sequelize version - 6.3.6

Hello @LizaAichi, welcome to forest!

I understand that you have an issue when you try to switch from a view to another with this button:
Screenshot 2020-08-13 at 15.18.57

I do not reproduce the problem on my side, I am able to switch from the table view to any smart view.

Can you please give more informations about the situation?
Does it worked previously / it never worked / it brokes since something happen?
Try again to change the view, then capture the full error log and share it here.

Thank you

I can switch too, but the selection I make isn’t saved(after page reload). Earlier it was working fine, I am not sure when it stopped working, as I haven’t been using views switching for a long time. Here is the screenshot with the error attached:


Can you please provide the name of your project?

Hi @Sliman_Medini, I PMd you the details of our project.
Many thanks

Hi @LizaAichi, @ATZ,

Thanks for your patience.

We reproduced the issue and have released a patch a few minutes ago.
If you refresh your browser page, you should now be able to reorder your views as usual.

Let us know if it works for you.

Yes, now it works, thanks

1 Like