"searchToEdit" not authorised

I cannot create new records because I can’t define the relationship with another table as the widget is disabled

This is what I see:

I hoped that I could enable this by going on the other table settings and enabling the “allow search to edit” toggle but that’s greyed out so I cannot do it.

In the logs I see the following:

'searchToEdit' access forbidden on partner

Could you please explain the causes that may lead to that error?

Hello @Antonio_Marino :wave:

Is your partner collection hidden or visible please ?


It is visible. Both collections involved in this are visible

I’m struggling to understand the problem because we have a similar setup on another pair of tables and it always worked there… the model/relationships also look very similar to those other tables (although that other pair is on a different database).

@Antonio_Marino Ok I see we have an issue there.

We are currently working on a fix, but I can’t give you any ETA for now. But, I can provide you a workaround to make things working back. Just follow these steps:

1 - Set the Partner collection as not visible using the layout editor
2 - Reach the Partner collection settings, and observe that the option is now clickable.
3 - Activate the option
4 - Save your changes
5 - Set back the Partner collection as visible
6 - Then you should be able to search using your widget as you are used to.

I hope this helped out, please keep me in touch :raised_hands:


This works, thanks for the quick solution

1 Like