Segment filter: doesnt apepar to support "empty string"

Feature(s) impacted

Setup Segment on Table

Observed behavior

Cant create a filter with is “empty”. If I don’t supply a value it will not let me create a filter on the segment.

Expected behavior

Should be able to create a file which allows for “empty string”


  • Project name: Foreign Exchange
  • Team name: Operations
  • Environment name: Production
  • Agent (forest package) name & version: Latest
  • Database type: MSSQL
  • Recent changes made on your end if any: N/A

Hello @David_Martin,

Ok, I just checked and indeed you can only check for null value with is blank operator.

Thank you for your feedback. :pray: I will pass it to our team without delay. We will see what we can do to improve your experience.

I will comeback to you when I have a proper timeline for this.

Kind regards,

1 Like

In the meantime, what version of the agent are you using ?

Another option is to create the Segment definition from your code base. So you will have full power on the filter you need to create.


Will give this a go and let you know. Thanks for the tip.


1 Like