Unable to see collections in remote environments

Configuring the layout doesn’t result in collections being shown in production and staging environments.

Expected behavior

When adding remote environments for production & staging, I should be able to see data.

Actual behavior

When I go to the newly created environments, I am instructed to configure or copy a layout. I have attempted manually marking all collections as visible as well as copying the layout from the development environment where data is showing.

However, each time, once I come out of layout edit mode, still no collections are shown. I also don’t see any errors in the ForestAdmin UI and minimal errors in console.

Failure Logs

Admin Backend shows no errors in server logs but also I do not see any requests for data. Only a post to /forest/sessions which gets a 304 response

2021-02-08T16:53:31.239825+00:00 heroku[router]: at=info method=GET path="/" host=autocategories-admin-prod.herokuapp.com request_id=d15331c0-7d25-4091-ad01-1221f87f83e7 fwd="" dyno=web.1 connect=0ms service=13ms status=304 bytes=292 protocol=https
2021-02-08T16:53:31.240441+00:00 app[web.1]: GET / 304 - - 6.931 ms
2021-02-08T16:53:31.347793+00:00 app[web.1]: GET / 200 10026 - 4.024 ms
2021-02-08T16:53:31.350652+00:00 heroku[router]: at=info method=GET path="/" host=autocategories-admin-prod.herokuapp.com request_id=3be71070-9b66-4c78-81be-2a791b284e5d fwd="" dyno=web.1 connect=0ms service=10ms status=200 bytes=10371 protocol=https
2021-02-08T16:53:31.802845+00:00 heroku[router]: at=info method=GET path="/favicon.ico" host=autocategories-admin-prod.herokuapp.com request_id=1a280e77-7471-42b4-84a0-c8954122ebbc fwd="" dyno=web.1 connect=0ms service=8ms status=404 bytes=448 protocol=https
2021-02-08T16:53:31.803900+00:00 app[web.1]: GET /favicon.ico 404 150 - 6.190 ms
2021-02-08T16:58:57.164776+00:00 heroku[router]: at=info method=OPTIONS path="/forest/sessions" host=autocategories-admin-prod.herokuapp.com request_id=93af7a0b-dd85-4ede-a2c6-092378fd6474 fwd="" dyno=web.1 connect=1ms service=3ms status=204 bytes=405 protocol=https
2021-02-08T16:58:57.167640+00:00 app[web.1]: OPTIONS /forest/sessions 204 0 - 0.730 ms
2021-02-08T16:58:57.521858+00:00 heroku[router]: at=info method=POST path="/forest/sessions" host=autocategories-admin-prod.herokuapp.com request_id=12e9630d-449e-44f2-afd0-ed1909044f71 fwd="" dyno=web.1 connect=0ms service=251ms status=200 bytes=969 protocol=https
2021-02-08T16:58:57.522595+00:00 app[web.1]: POST /forest/sessions 200 304 - 249.037 ms


Forest Backend is hosted on Heroku, pointing to a Heroku Postgres instance from another app. (I have this setup working for a different project).

  • Package Version: “^6.0.0”,
  • Express Version: “~4.17.1”,
  • Sequelize Version: “~5.15.1”
  • Database Dialect: Postgres
  • Database Version: 12
  • Project Name: Automated Categories

Thanks in advance for any help!

Hi @bobbyshaw ,

Your project is using the Roles ACL. Meaning that you just have shown the collections but you do not have the rights to access it. To be able to access them go to : Project Settings > Roles, select your role and enable the permissions. We are actually working on a screen to make it easier to understand that you actually do not have the rights :wink:


Thanks Vince. I was able to resolve the issue with your help. The role did have the right permissions but my user had “Admin” user permission but not the “Admin” role that I had created.

The onboarding flow guided me to create a role but I missed that I then needed to assign it to the currently logged in user.

Hi @bobbyshaw,

I believe we will iron out the permission level vs roles difference at some point, because this is somewhat confusing.
Thanks for the feedback about the creation of the first role, indeed you need to assign it on yourself: we should probably make that more intuitive.

1 Like