Collections always hidden

Trying to investigate on another project - for which I already created an issue - I created an entirely new project with lumber.

Expected behavior

Collections should be visible both in my development (local) and production (remote) environments. They access the same postgresql database.

Actual behavior

Collections are hidden on my production environment. I first tried copying the layout from my development environment, I received the confirmation email but I still can’t see my collections. Then I tried to make theme visible directly with the layout editor, still not working.

Failure Logs


Backend is hosted on Heroku. Nothing went wrong during the setup.

  "name": "test-cors",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "start": "node ./server.js"
  "dependencies": {
    "body-parser": "1.19.0",
    "chalk": "~1.1.3",
    "cookie-parser": "1.4.4",
    "cors": "2.8.5",
    "debug": "~4.0.1",
    "dotenv": "~6.1.0",
    "express": "~4.17.1",
    "express-jwt": "5.3.1",
    "forest-express-sequelize": "^6.0.0",
    "morgan": "1.9.1",
    "require-all": "^3.0.0",
    "sequelize": "~5.15.1",
    "pg": "~8.2.2"

  • Package Version:
  • Express Version:
  • Sequelize Version:
  • Database Dialect: postgres
  • Database Version:
  • Project Name: test-cors

Hi @AlexisSMT,

Thanks for the message.

Actually, you need to create a role with the rights to see the collections (and smart actions) you want to access.
And then assign this role to yourself to be able to browse the collections.

We are aware of this possible confusion, so we are currently working on an improvement to make it more understandable.

Let me know if it works!

Indeed adding my user a role with the right permissions did the trick!

If I want to add all permissions to a role, for each collection, I have to toggle 6 checkboxes. In my case it means 72 clicks. I guess some kind of a “toggle all” button would come very handy here

Anyway, issue is solved, thanks!

1 Like


Actually if you want all permissions, when creating the role, you should be able to choose to create the role “from everything allowed”.

Can you confirm you see this option?
It will be easier than clicking on all the boxes indeed :sweat_smile:

And just to let you know, you can also create a new role from an existing one (if it suits you better at some point).

I had already created a role as a message prompted me to do so. But I guess I’ve not been focus at some point and completely skipped the permission step, giving it no permission at all! So I had to edit it afterwards