Unable to update or delete segments

Hello there!

I have been using segments (Check backend details below) and I am trying to update or delete them but unable to.

Look at the video here for details.

As you can see, I deleted the Segment Labeled “Succeeded”. But when I refresh it, it shows up again. The same error persists when I try to update any details or filter conitions.

“forest-express-mongoose”: “^7.7.1”,
“express”: “~4.17.1”,
Project Name: Dibsy
Database: MongoDB

Hey @tanishp,

I’ll try to reproduce. Thanks for the bug report

Also please note that in remote environement the segments duplicate many many times. Check video.

P.S: I have hidden all the fields as it is sensitive information. It is not the problem.

Okey I just tried and I sadly do not reproduce your issue. I’ll try to check if I see any issue on your project :thinking:

I do see a lot of duplications in your segments. Did you create your segments this morning ?

The duplications happened automatically. I created my segments long time ago. Yesterday, I was implementing smart segments with the same name. Once I created them I found this error so I disabled them, and since then, I am unable to edit any of my segments.

Is there something you could in the “.forestadmin-schema.json” that is callibrated by forestadmin side (the forestadmin UI) ?

I would be alright if you delete all existing collection settings and I could set them again if that solves the problem.


I’ll try to clean your settings. Try to not update anything on your production for the next hour :pray:

Try to refresh and tell me if that is fixed for you ?

Yes, that solved the problem. I think the issue was:

When you create segments through the UI, and then create smart segments at the same time with the same name, it creates a conflict.

Thank you for your assistance.


Yeah I think you are right I’ll try to reproduce later :slight_smile:. Thanks :slight_smile: