Urgent: Smart Actions don't appear in local development environment

Nothing has changed in my code, and the actions appear in my settings menu for the table, but they do not appear in the drop down menu?

I have the same issue. :confused:

Relationships are also populating in the grid view, including has many relationships.

this is not working for us in production environment, and we need to use the smart action right now.

Hey all,

cross-posting here: we are aware of the issue and there’s currently three developers looking into fixing it.

I’ll keep you updated throughout the incident as soon as I have more news!

I am very sorry for the pain it generates, I know how much of an important feature this is

We also face the same issue - smart action disappears from the bottom-right corner of the dropdown menu

Before smart actions went away, the input fields in each smart action were also reversed from the bottom to the top. Not sure if that helps.

Update: we are still working on identifying the cause of the bug (there were several updates today) but we are committed to shipping the fastest solution. it will most likely be a rollback but we need to check if there are further steps needed to do it safely

@Matt: thanks! I passed that information to the developer team


Ok so it looks like we have identified the probable cause. It seems to be a backend issue introduced ~2 hours ago.

We’re now looking into how to revert this and what additional actions need to be taken (for example, emptying the renderings cache).


We successfully reverted the backend to a previous revision before the bug was introduced. We’re now looking into how the levels of cache could prevent users from getting they’re smart actions back but we should be close to the full solution.

1 Like


Fix has been deployed and all should be back to normal now. Although we can confirm the issue is solved for individual users, some might still experience problems due to caching.

We are currently taking the necessary steps to ensure all customers who made changes to the renderings after the bug is introduced get a fresh cache. There might be a way to speed things up by forcing a new rendering on your side, I will get back with more information.


While we are working to refresh the caches of all affected users on our end, if you are still waiting for your actions to come back, here’s the steps to manually refresh the cache on your end:

  • Open the settings page for a collection (any collection will do)
  • Navigate to the “Sorting field”, “Reference field” or “Display Name”, and change the current value to anything else
  • Save the changes (<-- this forces a cache refresh of the renderings on our end)
  • Go back to the setting you changed and rollback the changes to whatever value you had before
  • Save the changes

All of your smart actions should be back to normal within a short amount of time (between a few seconds and a few minutes - up to 5). If they still don’t show up make sure you force update the browser cache (Ctrl/Cmd+Shift+R).

Please comment if these instructions don’t work for you!


Final update

This is now its own post:

We’ll be releasing a post mortem in the coming days, and I will also update you as soon as all the caches are regenerated.

Thank you all for staying with us!!

1 Like

Just to confirm: all projects have successfully been refreshed and the incident is fully resolved - thanks for staying with us!

1 Like