Wrong environment selected - "Unable to authenticate you"

Expected behavior

After login and selection of the project, when I select one of the remote environments (production, for example), I am authenticated to the production environment.

Actual behavior

Error message is being shown:
Unable to authenticate you
Please verify that your admin backend is correctly configured and running.

I can see that the browser performs a request to localhost:3310 even though I have selected a remote environment. The url of the remote environment has been set correctly.

Cache clean, restart of the app has been tried.

Failure Logs

Please include any relevant log snippets, if necessary.


Please provide any relevant information about your setup.

  • Package Version: “forest-express-sequelize”: “^7.0.0”,
  • Express Version: ~4.17.1
  • Sequelize Version: ~5.15.1"
  • Database Dialect: Postgres
  • Database Version: irrelevant
  • Project Name: solardata_2

Hello @postolovskid and welcome to the Forest Admin community!!! :tada:

Did you check your APPLICATION_URL on your remote server is correctly configured?
This could be a clue.

Let me know :wink:

That seems to solve it, thanks. But, I have to let you know that it hasn’t been included in the autogenerated docker-compose.yml file.

1 Like

Thank you @postolovskid,

I’m happy it solved your issue :tada:
We will improve the autogenerated docker-compose.yml file based on your recommendations :smiley: