[bug] Collaboration don't link to the record but to the whole collection instead

Expected behavior

When I go on collaboration and click on a note, it should link to the record collaboration section opening the note form.

Actual behavior

It opens the whole collection.

Context

Firefox 91.0.2

"liana": "forest-express-sequelize",
    "liana_version": "8.0.9",
    "stack": {
      "database_type": "mysql",
      "engine": "nodejs",
      "engine_version": "14.17.0",
      "orm_version": "5.21.7"
    }

Project name: MyTraiteur

Overall, the collaboration feature feels a bit frustrating. When someone replies to you tagging them, imo you should get a notification. Also, emails only notification is a bit weak and easy to forget, a notification system inside the layout would be more convenient.
To show Harold that collaboration doesn’t work on my side, I created one on my dev env. Though, the collaboration note got created in production too! And it doesn’t work either in production, on 5 clicks it redirected me once to the actual note.

Cheers,

Hello @mathieuh,

Thank you for the feedback.

Let’s split differents subjects from your message:

  • Clicking a note, I’m redirected to the whole collection instead of the record.
    • I am unable to reproduce this behavior. Do you have something different from this video?
  • Tagged people in Notes should be notified inside the app instead of just a mail.
    • I notify the feature request in our product board in order to be prioritized.
  • A note created in dev was visible from production.
    • This was reproduced. When a record shares the same id, they also share the note cross environment. A bug ticket is created to fix it quickly. Thank you for pointing it.

Regards

Hi @Sliman_Medini,

Yes I get something different. When I click on the note I get redirected to the collection instead of the record collaboration board.

Cheers,

Hi @mathieuh,

Is this happening for all collections, or only for a subset of them? If only for one of them, would you mind sharing its definition/code so I can try to reproduce the issue?

Thank you

Hi @Guillaume_Deslandes,

Think I got it.

I works as intended on another collection.
The collection triggering the bug has Access to records through Segments only checked.
When I unchecked it, it worked.
Then I checked it again, it worked a couple of times before it broke again.

Let me know if you reproduce it.

Cheers,

Hello @mathieuh,

I confirm that I can reproduce this behaviour.

I filled a bug with our development team, and we’ll reply on this thread when this is fixed.

Thank you for this report, and sorry for the inconvenience.