Cannot add dev environment to Forest Admin

Feature(s) impacted

Set up development environment.

Observed behavior

Hello, I followed the documentation and “forest init” worked. My .env was correctly updated. Nevertheless, my development environment is blocked as a draft and I have this error:
“You need to finish deploying your environment Development | sam to see it live”
But when I click on “deploy”, it is written that my project is not found and it redirects my to the projects index, where I can correctly find my projet.

Expected behavior

I would like to use my development environment.


  • Project name: Squarehub
  • Team name: Squarehub
  • Environment name: Automations
  • Agent (forest package) name & version: sam_branch
  • Database type: …
  • Recent changes made on your end if any: /

EDIT: Manually removed the screenshot
← Removed →

Hey @samrozen, and welcome to our community :wave:

Did you start your development server once the .env was updated ?

On my end, I can see that indeed, your development server was never initialized. That may explain the issue you are having: Your server should be accessible/running to finalize the creation of this new environment


Solved. Thank you ! :pray:

1 Like