Dev Environment Stuck on "Your project is being configured."

Hi -

We recently updated our forest-cli version and upon creating a new forest branch, our development environment is now stuck on “Your project is being configured.” I’ve tried deleting the .forestadmin-schema to see if that would help, but it doesn’t.

Could you look into this, please?


Hello @yeti182,

Could you please share with us the exact command that you launched?

Also, could you please share the required info when creating a post in the community?


<!-- ⚠️ This is a template you must use to report issues. ⚠️  -->
<!-- You can also drag images, videos and include pre-formatted text.  -->

## Feature(s) impacted
<!-- Please describe in this mandatory section the feature(s) that will be discussed in this topic. -->

## Observed behavior
<!-- Please describe in this mandatory section the current behavior you observe. -->

## Expected behavior
<!-- Please describe in this mandatory section the behavior you are expecting. -->

## Failure Logs

<!-- In this optional section, please include any relevant log snippets if necessary. -->
<!-- Or remove this section if left empty. -->

## Context

<!-- Please provide in this **mandatory section**, the relevant information about your configuration: -->
- Project name: ...
- Team name: ...
- Environment name: ...
- Agent (forest package) name & version: ...
- Database type: ...
- Recent changes made on your end if any: ... 

Hi @GuillaumeGautreau - happy to, but I’ll send the private details in a DM, if that’s okay.

Command to launch is the one we’ve always used: nodemon ./server.js

Features impacted

Ability to access dev environment

Observed behavior

When loading our development environment, it is stuck on “Your Project is Being Configured”

Expected behavior

It should load…

Failure Logs




It looks like the start of our issue coincided with a Forest API degradation. I’ve tried logging out/logging in as well as a different browser, but the issue persists. Could you please check to see if something happened related to this outage: Users cannot execute variou... | ForestAdmin

We’re unable to complete any development due to this issue - any help would be appreciated!

Hello @yeti182,

Thanks for pointing out the recent issue we had. I’m still investigating if it affected your particular environment.

In the meantime, I re-launched a processing on your project that should normally allow you to access it. Could you please make a try?

If it’s not the case, could you please open the developer tools in your browser and report any error from the console?


My investigations show that there is still a problem with your development environment.

We are continuing investigations to understand the impacts of yesterday’s incident on your environment and to fix the issue.

I’ll keep you posted when I have news.

It seems that your schema contain invalid declarations of some enum fields:

            "type": "Enum",
            "enums": null,
            "field": "currentSpeechEngine",
            "inverseOf": null,
            "isVirtual": true,
            "reference": null,
            "isReadOnly": false,
            "isRequired": false,
            "isSortable": false,
            "integration": null,
            "validations": [],
            "defaultValue": null,
            "isFilterable": false,
            "isPrimaryKey": false


            "type": "Enum",
            "enums": null,
            "field": "Subscription Plan ID",
            "widget": null,
            "position": 2,
            "reference": null,
            "isReadOnly": true,
            "isRequired": true,
            "description": "This is automatically populated based on the selected subscription plan.",
            "defaultValue": null
            "hook": "onSubPlanChange",
            "type": "Enum",
            "enums": null,
            "field": "Subscription Plan Name",
            "widget": null,
            "position": 1,
            "reference": null,
            "isRequired": true,
            "description": "This is the type and price for new the subsription.",
            "defaultValue": null

In all of these cases, it’s not valid to have both "type": "Enum" and "enums": null. The value of enums must be an array.

I think the problem comes only from the first one, that declares an enum in the collection Users.

We’re working on correctly handling this kind of invalid declaration, but in the meantime can you try to fix the declaration on your side?

Small update: we managed this invalid value case on our side, and your project should be fully usable now.

Thank you for reaching us about your issue.

1 Like

Hi @GuillaumeGautreau -

Thanks for the update, and we are able to use our dev environment now. Looks like the null enums field was due to a misspelling of enums as enunms in our config. The issue must not have cropped up until we made a new branch. Thanks for getting us up and running again!

1 Like