Unable to see my development environment

Expected behavior

I want to see my development environment

Actual behavior

I see nothing

Context

When I run forest init I see the message √ Setting up your development environment.

I see my development when I run forest deploy: Development | aurélienXXXXX (but it doesn’t work with the message × source and destination environments must have the same schema), but I don’t see this environment on the Forest admin interface

.

However I can see my branch.

What I’m doing wrong ?

Please provide any relevant information about your setup.

  • Express Version: forest-express-mongoose@^8.3.0
  • Database Dialect: mongodb
  • Database Version: 4.0
  • Project Name: Intent
  • Logged with google

Hi @aurelien.laclergue,

Thanks for your message :raised_hands:

I might have not understand something here: I am not sure why you’re trying to deploy the layout changes of your development environment if you actually can’t access it on the UI (then I guess there are no layout changes possible).

We did not receive any schema yet for this development environment.
Did you try to start your local admin backend (the one matching Development | aurélienXXXXX)?
When you do, do you have any error in your console?

Thanks.

Hi adriguy :slight_smile:

I tried deploying because i thought maybe that was the right thing to do to make it work. But it was just a try.

Yes, I try to start my local admin backend, and when I try to go to http://localhost:3310/ I can see the message “Your application is running!”, and no error in my console.

I don’t understand why I see only 4 environments in the project settings, but when I inspect network I can see 6 environment, with my development environment (id 81196). Why it does not appear in the UI ?

Thanks

Hi @aurelien.laclergue,

Thanks for your answer.

That is very strange :thinking:
Just to be sure, would you mind sharing the last 4 digits of your ENVIRONMENT_SECRET you have in the .env file of your local admin backend?

Thanks.

Sure, it’s a0ca.

Thank you for your help.

Hi @aurelien.laclergue,

You development does not appear on the UI because it does not have any schema.
The schema is the description of your database and its configuration.
The schema is sent by your server when it starts successfully.

Can you please check the logs of your server when it starts?

Regards

I @Sliman_Medini :wave:

As I said, I have no errors in my server. Just a warning which is not the problem:

More over, I try to add console.log on file node_modules/forest-express/dist/services/apimap-sender.js:45 like this:

console.log({
          statusCode: result.statusCode,
          apimap,
          path: result.req.path
        })

And the result is:

{
  statusCode: 204,
  apimap: {
    data: [
      [Object], [Object],
      [Object], [Object],
      [Object], [Object],
      [Object], [Object],
      [Object], [Object],
      [Object], [Object],
      [Object]
    ],
    included: [ [Object], [Object], [Object], [Object] ],
    meta: {
      liana: 'forest-express-mongoose',
      liana_version: '8.3.0',
      stack: {
                "database_type": "multiple",
                "engine": "nodejs",
                "engine_version": "12.16.2",
                "orm_version": "5.8.13"
            }
    }
  },
  path: '/forest/apimaps'
}

Where “data” is a list of all my collections and “included” is a list of my actions. I can copy/paste a complete JSON of this, but there are 4033 lines :confused:
Also, I check the forest-secret-key set for the request, and it’s the same value as .env file.

So I guess the schema is well sent by my server.

Ok,

For some reason we do not catch your schema.
Can you please run the command forest schema:apply?

Regards

1 Like

Of course,

this is the result :slight_smile:

Are you able to browse your environment now?

Yes, but I can’t login to it

Same error in the server

Can you please check your FOREST_ENV_SECRET value on your server?
Using console.log(process.env.FOREST_ENV_SECRET) to double check may help configuration loading issues.

The value should be the same than the value displayed on the environments page.

Ok, it’s not the same as in my .env file :thinking: the process.env.FOREST_ENV_SECRET finish with a20a. In my .env file it’s finish with a0ca

Ok!

Please consider that if you set the env secret of another environment, this will update the schema of this other environment.

Is it all good now?

Regards

Yes it works ! Thank you both of you :slight_smile:

1 Like