Doesn't see my Development environment

Expected behavior

When running my devlopment environment locally, be able to see the env in the upper left drop down, and select it.

Actual behavior

I actually see only my Prod and Staging env

Context

Please provide any relevant information about your setup.

  • Package Version: 4.0.2, same behaviour when updgraded to 6.0.0
  • Express Version: 4.16.4
  • Sequelize Version: 4.8.0
  • Database Dialect: MySQL
  • Database Version: 5.7
  • Project Name: Blueboard’s backoffice

Same here.
If I select staging env Development environment is magically appear.

Thanks for your reply. I’ve tried that already but it doesn’t appear for me. I’ve check and my environment is still set up.

I’ve also tried creating a new dev env, I’ve managed to set it up but doesn’t show either.

Hi :wave: welcome to our community and thank you for using Forest Admin.
Have you got any errors logs on your browser console ?
Can you provide me the result of
https://api.forestadmin.com/api/teams/XXX/renderings
https://api.forestadmin.com/api/projects/XXX/environments
API calls please ?

Hello Arnaud,

I’ve got some cors errors on the console but it’s not from forestadmin api.

Both the request returns a 304 with what seems to be a normal content (don’t know if I can safely share it here). What’s strange is that both my local env are visible in the response of /environments

Can you access your environment by url ?
https://app.forestadmin.com/Blueboard’s%20backoffice/Development/Operations
If you can, what do you see in environments selector ?
If you see the Development one, can you switch to another and what do you see again in environments selector ?

Ok it has works thanks a lot. Also other local env have appeared.
For information I’ve tried accessing directly by url before but I was missing my team suffis /Operations and it didn’t worked.

Thanks.

Ok cool, last thing, can you switch again and try to return on your Development environment with the environments selector ?

Ah yes switching back makes the env disappears again. URL still works tho.

Can we test one thing ? If you are ok i’m going to refresh your rendering cache to see if the issue come from here. We will try with your Development environment.

If that impact only the Development env, yes go ahead

Can you try again ? Is that the environment now appears ?

Ok now I see both my local env from my prod / staging ones.

Thanks for your help. :slight_smile:

Would you like me to do the same on your Dev environment ?

No it was a test I’ll delete it, and I can see it also.