Unable to access development environment

Expected behavior

I would like to be connected to my local server when selecting the development env.
I have created a local branch with the forest cli forest branch my-branch-name

Actual behavior

I’m automatically logged out when trying to access my development environment, and a page with Our server encountered an error is briefly showing

ezgif.com-gif-maker

Failure Logs

No logs in my local server.
In the browser there are some errors showing up in the console:
Uncaught (in promise) RangeError: Maximum call stack size exceeded

Context

Please provide any relevant information about your setup.

  • Package Version: “forest-express-sequelize”: “6.5.0”
  • Express Version: “express”: “^4.17.1”
  • Sequelize Version: “sequelize”: “6.3.0”
  • Database Dialect:
  • Database Version:
  • Project Name:

Hi @Alexandre_Behaghel :wave: welcome to our community.
What is you project name please?

oh sorry, it is “Inato Marketplace”

Unfortunately I can’t reproduce.
Do you observe the issue on each branch you created?
The other members of your team encounter the issue?

Yep, have the exact same problem here.

I did delete my branch and recreated a new one, does not change anything.

I have also deleted then recreated my dev env, still doesn’t work.
We have even removed me from the team and get me back, still nothing…

Hi @Alexandre_Behaghel and @Thierry_Colsenet :wave:

Sad to see this issue.
This is hard-to debug situation because all traces are ok on our monitoring tools.

In order to have more information, can you please answer the following (numerous sorry :stuck_out_tongue: ) questions?

  • Can you please provide a HAR which is the log of the requests made by the front-end? (how-to at the end of this message)
  • Do you remember a significant change that happened before the issue appear?
  • For one environment/team, does the issue appear every time or sometimes only?
  • Does the issue appear for every team of the environment?
  • You have 13 development environments. Do they all encounter the issue?
  • Did you notice any configuration difference between working and failing dev environments?
  • Does your production encounter the issue?
  • Does your staging encounter the issue?

How to generate a HAR:

  • Browse the failing env with chrome
  • Open dev tools
  • Locate network tab, clear it
  • Reproduce the failing use case
  • Right-click on the network calls list and choose “save all as HAR with content”

Thank you

Hi @Sliman_Medini

No worries, we definitely get it’s hard to reproduce.

Ok really weird behavior, I had the issue last Friday, I did reset my access (FOREST tokens) and created a new branch. It did not work, same as Alex.
Yesterday it worked, perfectly, just after a pull + yarn on our project. I could access my local env with Forest, no issues.
Today it does not work anymore. I haven’t cchanged anything. I did try to pull + yarn again, does not change, anything, still does not work :grimacing:

  • I’ll give the HAR
  • Nope, nothing changed between yesterday and today
  • So apparently, for my env it appears sometimes, but not all the time. I think Alex environement used to work, not anymore so same, not always buggy.
  • AFAIK only Alex and me have the issue. I know one of our developers needs to connect through private browsing for Forest to work, but it doesn’t cchange anything for Alex and me.
  • I don’t think so
  • production and staging env work great

what’s weird is we get a 401 :man_shrugging:

actually the HAR is 40Mo, sounds like a loooot, maybe I can only send you what I get in the 401?

Hi @Thierry_Colsenet,

Ok.
The entire HAR is preferred, so do not hesitate to put it on a file share platform.
Are you sure you have only one server instance for your dev? (Maybe a machine restart will ensure this)
Are you in the same location between when it works / when it fails?
Do you have common things with Alex others developers do not have? Browser, user, role, layout details,…
Also, we released fixes today, are the issue still here now?

One last idea: can you please list your browser extensions (like duckduckgo) and also for Alex.

Sorry, these are vague questions - not really a certain solution. But since every where else it’s working, we have to find the detail which is different.

Regards