How do I deploy my branch to a staging environment?

Hi there,

we’ve upgraded our environments to use the new branch based workflow, but I’m very much confused about the deployment process.
I’ve been reading the docs and I created my branch and now I want to deploy it first to our remote staging environment. We have two remote environments staging and production and usually, we deploy first to staging so the changes can go through a testing phase and after that, if everything looks good we deploy to production.

I’ve been reading the docs for the deploy command (deploy - Developer guide) but it only explains how to deploy the changes to the origin environment.
I’m stuck and would appreciate any help here.

Also, I went through the deployment process thinking that I would deploy to my staging remote environment and even though the CLI says Deployed Dev-ng (our staging env) layout changes to reference environment, my branch on FA still says:


I don’t understand what’s happening. I’d be up for a call so you can guide us on the workflow if possible. I’ve read the all doc pages for this new workflow, but I’m still stuck :grimacing:

I tried using the push command, but I get this error: Failed to push branch: Source and destination environments must have the same schema. Please check your environment's code is synchronized and I’m not sure what I should do.

Do you have the same source code between your development and the remote environment ?


deploy => Deploy layout changes of an environment to the reference one.
push =>  Push layout changes of your current branch to a remote environment.

Let me know if it helped you.

Hi @Alban_Bertolini yes, I haven’t changed any backend code and there I wouldn’t expect the schema to change. I think the error was thrown because I ran the server locally and I don’t know why Forest added a bunch of spaces to the .forestadmin-schema file even though I haven’t changed anything in the backend code and therefore I’d get this complaint that the schema in the remove environment is not the same. I deployed the new schema (with the spaces) and now I could push the layout changes to my staging environment. The same error is thrown if you try to deploy. Now it seems to work fine.

1 Like